【一本通】 用递归函数求x!


💐The Begin💐点点关注,收藏不迷路💐

用递归函数求x!

阶乘 (x!) 的定义如下:
x ! = { 1 ( x = 0 ) x ( x − 1 ) ! ( x > 0 )   x! = \begin{cases}1 & (x = 0) \\x(x - 1)! & (x > 0)\end{cases}\ x!={1x(x1)!(x=0)(x>0) 

输入

整数x,x不大于12

输出

n!

样例输入

3!

样例输出

6

#include <stdio.h>

// 递归函数计算阶乘
int factorial(int x) {
    if (x == 0) {  // 如果x为0,按照定义返回1
        return 1;
    }
    return x  factorial(x - 1);  // 否则按照递推公式x  (x - 1)! 计算
}

int main() {
    int x;
    scanf(“%d”, &x);  // 输入一个整数x
    int result = factorial(x);  // 调用factorial函数计算x的阶乘
    printf(“%d\n”, result);  // 输出结果
    return 0;
}

在这里插入图片描述


💐The End💐点点关注,收藏不迷路💐
Logo

科技之力与好奇之心,共建有温度的智能世界

更多推荐